Memory Map “Failed To Terminate RS232 Thread”

For those of you who (like me!) have been plagued by problems getting your GPS unit to communicate with Memory Map and keep seeing the error message ‘Failed To Terminate RS232 Thread‘, maybe this will help…

I came to the conclusion that Memory Map thought that something else was hanging on to the serial port, in my case COM1. I tried various things to try and fix the problem, including reinstalling Memory Map, but none of them worked. Finally, I deleted the COM port from the hardware setup, and let Windows find it again when it rebooted. That caused it to reinstall the port driver software and it seems to have fixed the problem (at least for now ) – hooray!

Goto the Start menu, click on Control Panel, double click on the System icon, select the Hardware tab, click the Device Manager button, find the Ports (COM & LPT) entry in the list and click on that to open it up, highlight the COM port that you want to fix (probably COM1. at least it was in my case), highlight that and press your Delete key. Windows will warn you that you are about to delete the port, click the OK button on the warning box. Go back to the Control Panel and double click the Add Hardware icon. Windows should then search for hardware that it doesn't know about, find the serial port and reinstall the driver for it. That did the trick for me.

I had the GPS connected to the serial port and switched on while I did all that but I don't think that would make any difference. If the fix doesn't work for you with your GPS not connected, connect it and try again. I hope that sorts your problem out!

Did this help you fix your ‘Failed To Terminate RS232 Thread problem'?

If this post helped you, please add a comment below. I'm curious to know how many people were suffering from the same problem.

Be Sociable, Share!

2 Responses to “Memory Map “Failed To Terminate RS232 Thread””

  1. yes it worked for me – did not need to reboot

  2. Holy Post Resurrection!

    I’m glad it helped, Paul.

    Since I wrote the post I bought a USB-Garmin lead so I can use Memory Map on my laptop which doesn’t have an RS232 port. The new setup has been almost 100% reliable. The crashes that I used to get virtually every time that I used MM are now a thing of the past.

Leave a Reply